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Document Disclaimer 
The information contained in this document has been carefully checked and is believed to 
be reliable. However, no responsibility can be assumed for inaccuracies that may not 
have been detected. 

CATC reserves the right to revise the information presented in this document without 
notice or penalty. 
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trademarks of Computer Access Technology Corporation.  
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registered trademarks of Microsoft Inc. 

All other trademarks are property of their respective companies. 

Copyright 
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copies should contain this copyright notice.  
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1 Introduction 
Multi-Protocol Analyzer (MPA) is an application designed to allow users to simultaneously 
control different types of CATC analyzers and to analyze the resulting traces in a single 
integrated interface.  MPA was developed to simplify design work in storage industry 
environments where data often moves from one type of link to another - for example, from SAS 
to Fibre Channel.  
 
MPA displays traces in a single user interface, thereby simplifying the process of analysis. 
 
Currently, MPA works with three storage protocols:  SAS, Serial ATA, and Fibre Channel. 
 
MPA runs on a windows-based PC.  The software requires Windows 98SE®, Windows 2000®, 
Windows ME®, or Windows XP®. 

1.1 System Requirements 

Currently the supported analyzers include: 

• FCTracer software 2.10 (or higher) 
• SASTracer software 2.0 (or higher) 
• SATracer software 4.0 (or higher) 

This document is for MPA software 1.00. 

1.2 Support Resources 
For the latest release of MPA software, please refer to CATC’s web site: 

www.catc.com/support 

2 What's In this Document 
This document describes the differences and additions between current analyzer software 
application and Multi-Protocol Analyzer. 
 
A lot in the operation of the Multi-Protocol Analyzer is modeled of the multi-unit recording 
approach currently existing in FCTracer and now in SASTracer and SATracer. 
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3 Software Overview 
The MPA application is a multi-protocol application that allows engineers to simultaneously 
record and analyze Fibre Channel, Serial ATA and SAS traffic.  MPA works in tandem with 
CATC's storage analyzers.  Engineers can attach two or more different types of analyzers into a 
multi-protocol test system and then configure the analyzers to record simultaneously.  
Afterwards, the traces from the different protocols can be uploaded into the MPA application and 
viewed and analyzed side-by-side. 

MPA makes use of whatever CATC analyzer software has already been installed.  MPA detects 
the installed analyzer software and then integrates the software's tools and buttons into the MPA 
interface. 

If installed without supporting analyzer software, MPA will display generic buttons common to 
all storage analyzers.  Protocol-specific buttons, however, will be absent.  The screenshot below 
shows MPA on a system that lacking other analyzer software.   

 
An example of MPA installed on a system without FCTracer, SASTracer, or SATracer.  Compare this 
screenshot to the one on the following page.  Note that many buttons are missing (for example the decode 
buttons).   

On a system where FCTracer, SASTracer, and/or SATracer have been installed, MPA takes the 
toolbars and menus of each application and places them at the top of its window.  The result is a 
single integrated interface that has the tools and buttons of each analyzer applications.   

When a trace is opened, MPA activates the tools relevant to the trace.  For example, if a Fibre 
Channel trace is opened, the FCTracer decode buttons are activated.  Concomitantly, the buttons 
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for other protocols, such as SASTracer decode buttons, are grayed out.  The same also happens 
when two or more different types of traces are open:  clicking in a trace activates its buttons. 

 
MPA on a system that has FCTracer and SATracer installed.  In this example, a Fibre Channel trace has 
been opened.  The lower toolbar shows that the FCTracer decode buttons (on the left) are active while the 
SATracer decode buttons (on the right) are grayed out.  Were a SATracer trace to be opened, FCTracer 
buttons would be inactive and the SATracer buttons would be active. 

4 Software Installation 
To install MPA software, insert the MPA software CD and follow the onscreen instructions.  
Afterwards, when the MPA application is started, MPA will add the toolbars of any analyzer 
software that it detects on your system to the MPA window.   
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5 Analyzer Setup 

 
A hypothetical test setup: a Serial ATA hard drive connected to a bridge, and the bridge, in turn, is connected 
to a Fibre Channel HBA.  Two cascaded analyzers are placed on the links and administered by a laptop 
running MPA.  In this setup, MPA will be able to instruct both analyzers to simultaneously record, give the 
recordings a common timestamp, and afterwards analyze the two traces side-by-side. 
 

Setting up the analyzers involves creating up to three types of connections:   
 
1.  Analyzer to Test Device connection - This is the connection used to record traffic.  The 

analyzer is placed between nodes on a link - for example, between a Serial ATA hard drive 
and an adapter.   

 
2. BNC connection between analyzers - This is an important connection that allows multiple 

analyzers to work together.  BNC cables are connected from one analyzer to another in a 
loop fashion to what is known as a cascade.  A cascade is a group of analyzers that operate 
together as a single, logical unit.   
 

 
An example of a cascade.  The addition of BNC cables allow the analyzers to share clocking information 
and commands - thereby creating the cascade. 
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If you do not attach BNC cables between the analyzers, the analyzers will 
not be able to synchronize.  If you attempt to record with MPA without first 
attaching BNC cables, an error message will be generated that says Unable 
to Start Recording.  Sync error has occurred.  
If you are only planning to run one analyzer at a time, you do not need to 
install BNC cables.  However, you will need to run the corresponding 
analyzer software rather than MPA. 
A second example of a cascade.  In this example, four analyzers are connected by 
BNC.  The cables form a loop:  the output of one analyzer connects to the input of the 
second and so on through the cascade.  The output of the last analyzer connects back 
to the input of the first. 

3.  Analyzer to host PC connection - This is the administrative link used by the analyzer to 
send commands to the analyzer and retrieve traces from the analyzer's buffer.  This link is 
required for all analyzers. 

Two types of PC to Analyzer connection are possible:  local and remote.   

• Local connection - A USB connection between a PC and an analyzer.  This is the most 
common setup.   

• Remote connection - A PC connected to an analyzer remotely over an IP LAN.  This 
type of setup is useful when you do not need to be physically present to administer the 
test setup.  Remote access requires that analyzer software be installed on the local and 
remote hosts.  It also requires that the networking option be enabled during software 
installation (you will be asked if you want to enable networking).  

 

6 Starting MPA 
MPA can be started from the Start menu:  Start > Programs > CATC > CATC Multi-Protocol 
Analyzer. 

7 Establishing a Connection between MPA and an Analyzer 
Connections are established automatically for local analyzers as soon as MPA and the analyzers 
are up and running.  You can verify this connection, however, by opening the Analyzer 
Network dialog.  It will list all analyzers that it can detect.  For remote analyzers, you will need 
to map a connection to the remote device and establish a connection  Establishing a connection 
to a remote device is also achieved with the Analyzer Network dialog box. 
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7.1 Verifying a Connection to Local Analyzers 
You can verify that MPA has connected to one or more local analyzers by opening the Analyzer 
Network dialog. 

Select Setup > Analyzer Network from the MPA menu.   

 
The Analyzer Network dialog opens. 

 
If a device is locally attached, its serial number will appear in the first line of the dialog next to 
the label Local Machine.  Local machine is always listed in analyzer network and cannot be 
removed from the list. 

7.2 Connecting to Remote Analyzers 
The same process as described above will enable you to connect to a remote analyzer over an IP 
LAN.  Since CATC analyzers do not have IP LAN cards, you network to them via their host 
PCs.  The PCs connect over IP and, in turn, communicate with the analyzers via USB. 
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On each computer participating in analyzer network, networking will need to be configured.  
Networking configuration is an automatic process that can be enabled when you first load the 
analyzer software (you will be asked if you want to run your analyzer over a network).   

You will need to install analyzer software and enable the networking option on all PCs 
participating analyzer network.  Thus, for example, if you wanted to be able to run an FCTracer 
analyzer in the lab from the PC at your office desk, you would need to install FCTracer software 
on your office PC and the lab PC and would need to enable networking on both PCs. 

7.2.1 Mapping a Connection 
To map a connection to a remote analyzer,  

Step 1 Open the Analyzer Network dialog by selecting Setup > Analyzer Network… from 
the menu. 

 
 
The Analyzer Network dialog opens. 
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Step 2 Click the Add … button.  The Network Browse dialog opens and displays the names 
of the computers in the same domain as the local PC.  To connect to a PC on a 
different domain, enter its path.  Note: You can also enter IP addresses into this 
dialog. 

 
Step 3 Browse to the PC that has an analyzer and click it in the list. 
 
Step 4 Click the Select button.  MPA then connects to the analyzer on the selected PC and 

adds the PC's name and analyzer information to the Network Browse dialog. 

 
Step 5 Click Close to close the Network Browse dialog. 

8 Configuring a Recording 
Recordings are configured via the Recording Options dialog.  You can access this dialog from 
places: 

• Clicking the Recording Options button on the toolbar.   
 

• Setup menu - Has an option called Default Recording Options which allows you to open 
the Recording Options dialog with the default settings. 
 

• Devices menu - This menu will list the analyzer names.  Clicking on an analyzer name 
opens a sub-menu with an option for opening the Recording Options dialog. 
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• Devices menu - All Connected Devices - This option opens a dialog with options for 
opening the Recording Options and for updating the BusEngine, Firmware, and Software 
License.  

8.1 Configuring Recording Options via the Connected Devices Dialog 
As just mentioned, the Connected Devices dialog has a button for accessing the Recording 
Options dialog.  To access this dialog, 
Step 1 Select Devices > All Connected Devices from the menu. 

 
The Analyzer Devices dialog box displays.  This dialog lists all analyzers that are currently 
connected to MPA.  On the right are grayed-out five buttons.  Select an analyzer to activate the 
buttons. 

 
• About - Opens the About dialog for the selected analyzer.  Presents versioning 

information about the selected analyzer (Software, BusEngine, Firmware). 
• Update BE/FW - Opens a dialog for updating the BusEngine and Firmware. 
• Update License - Opens a dialog for updating the software license. 
• Recording Options - Opens the Recording Options dialog. 
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Note:  You can check/uncheck the box left from analyzer device serial number to 
include/exclude the device in/from recording. 
Step 2 Select an analyzer from the list. 
 
Step 3 Click the Recording Options button.  The Recording Options dialog opens. 
 

 
 
Step 4 Configure your recording.  For information on the Recording Options dialog, consult 

the Online Help or your analyzer user manual. 

Step 5  Click OK to close the Recording Options dialog.  The analyzer is now ready to 
record. 

Step 6 If you planning a multi-analyzer recording, repeat Steps 2 through 4 for remaining 
analyzers. 
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9 Configuring Display Options 
To change the colors and format of the trace, open the Display Options dialog and edit the 
settings.  This dialog controls the appearance of the trace. 

Select Setup > Default Display Options…  

 
Select the analyzer software that you wish to configure.   

The Display Options dialog opens.  Edit the settings, then click OK. 
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10 Recording 
Once the Recording Options have been set, you are ready to begin recording.  To start the 
recording, press the Record button.  This will cause all connected analyzer devices specified in 
setup to record. The progress control that shows the recording status for each device appears at 
the bottom of the main application window: 

 
The traces for each device will appear as soon as the recordings have finished and the traces have 
been uploaded to the PC. 

When all devices finish the recording this progress bar disappears. 

In cascaded setups, the analyzer that triggers first causes the other analyzers to trigger in the 
loop, and the analyzer that stops recording first stops the others. 

When multiple devices are participating in the recording, a trace is created by each analyzer.  In 
addition, a multi-trace file is created.   
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11 Working with Traces and "Multi-Trace" files 
MPA allows engineers to open and work with several traces simultaneously and synchronously. 
If the traces were created by a cascade, then two kinds of files will be created:  trace files (one 
per analyzer), and a special index file called a "multi-trace" file.  A multi-trace file is a kind of 
book-keeping file that MPA uses to keep track of traces created by cascades.  A multi-trace file 
has a .mpat extension.   

11.1 Opening a Multi-Trace File 
To open a Multi-trace file, select File > Open and then select a Multi-trace file (*.mpat). 

11.2 Creating a Multi-Trace File 
The usual method of creating a multi-trace file is to perform a cascaded recording of two or more 
analyzers.  A multi-trace file will automatically be created.  If desired, however, you can 
manually create a multi-trace file from regular trace files: 
 
Step 1 Select File > Open.  The Open dialog opens.  The File > Open dialog shows the file 

extensions for all registered analyzer software products: 

 
 
Step 2  Select two or more files in the dialog. 
 
Step 3 Click the Open button.  The files simultaneously open and display side by side in the 

MPA window.  A temporary multi-trace file is created. 
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Step 4 To preserve the multi-trace file, select File > Save Multi-Trace.  You will then be 

prompted to provide a name and path for the new file. 

11.3 Trace Panes 

The Trace Panes button ( ) on the toolbar opens a dialog for tiling the windows vertically or 
horizontally and aligning events from one window with those of another.   

 

11.3.1 Tiling Vertically or Horizontally 
To tile windows, select from one of the two radio buttons:  Vertical and Horizontal.  As soon as 
you have made a selection, the open windows will automatically tile as directed. 

11.3.2 Aligning Events between Windows 
The Time Offset button lets you add time offsets to windows in order to align events between 
traces.  This utility is designed to synchronize the windows in order to compensate for latencies 
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that might occur on links as traffic moves from one protocol to another.  For example, if there 
was a 20 ns delay as traffic moved from SATA to Fibre Channel, you could add 20 ns to the 
timestamps in the Fibre Channel trace window and thereby align the SATA and Fibre Channel 
traces.   

To add an offset, click the Time Offset button.  This will let you edit the Sync time offset (ns). 

11.3.3 Synchronizing Windows 
Windows can be synchronized or de-synchronized by selecting/de-selecting the checkboxes 
under the Sync column.   

De-synchronization allows for it to be scrolled separately, without scrolling all the other traces. 
Also, for each of the traces you can enter the time synchronization offset (expressed in 
nanoseconds) that can be used for compensating synchronization shifts or eliminating latencies. 

Synchronization/de-synchronization and minimization for individual traces in a multi-trace 
window can be also performed by pressing the buttons in the upper-right corner of each 
trace. 

12 Reports in MPA 
In the MPA toolbar, two groups of buttons exist.  The first group acts upon all the traces in 
multi-trace window and presents results in the single window, docked to the multi-trace window. 
This group includes 

Reports that Act Upon All Traces in MPA 

• Traffic Summary 
• Error Summary 
• Bus Utilization 

Reports that Act Upon only the Selected Trace 

• File Information 
• Timing Calculator 
• Data Bar 
• Link Tracker 
• Frame Tracker 
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12.1 Traffic Summary 
The Traffic Summary report for multi-trace is placed in a common window, with a separate 
report tree for each one of the participating traces. 

 

12.2 Bus Utilization 
The Bus Utilization report for multi-trace is placed in a common window, with a separate graph 
tree for each one of the participating traces. All the displayed graphs are synchronized and can be 
scrolled, zoomed in/out etc. accordingly. 
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12.3 Link Tracker 
The Link Tracker window displays traffic chronologically on a Primitive-by-Primitive basis. 
To opens the Link Tracker, click in a trace window, then press the Link Tracker button.   

Two or more Link Tracker windows can be synchronized and scrolled together.  To synchronize, 
open the Trace Panes dialog described earlier, and select the Sync checkboxes for the traces of 
interest.  Once the traces are synchronized, you can scroll either the traces or their Link Tracker 
windows and all will scroll together. 
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12.4 Frame Tracker 
The Frame Tracker window displays traffic chronologically on a Frame-by-Frame basis. 
To opens the Frame Tracker, click in a trace window, then press the Frame Tracker button.   

Like Link Tracker, multiple Frame Tracker windows can be synchronized and scrolled together.  
To synchronize, open the Trace Panes dialog, and select the Sync checkboxes for the traces of 
interest.  Once the traces are synchronized, you can scroll either the traces or their Frame Tracker 
windows and all will scroll together. 
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13 Miscellaneous 
The About dialog box shows all analyzer technologies that are registered for work with Multi-
Protocol Analyzer.  To access this dialog, select Help > About.  The About dialog opens: 

 

14 SAS/SATA Specifics 
By default MPA connects all SAS/SATA devices as SASTracer devices. However, if the user 
wishes to use a SAS/SATA device as an “SATracer device,” they can do so through the Devices 
menu.  (This assumes that you have installed SASTracer version 2.0 and SATracer version 4.0.) 

Two checkbox menus are appended to the normal Devices menu:  

• Use as SASTracer  

• Use as SATracer 

 
 
This gives the user the flexibility to decide how to use each connected device within the Multi-
Protocol analyzer environment. 
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15 Online Help and the User Manuals 
Detailed instructions on the operation of SASTracer, SATracer, and FCTracer can be found in 
the user manuals and Online Help for each product.  The MPA Help menu provides links to the 
Online Help for each installed product.   
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How to Contact CATC   
Type of Service Contract 
Call for technical support… US and Canada: 1 (800) 909-2282 

Worldwide:  1 (408) 727-6600  
Fax your questions… Worldwide: 1 (408) 727-6622 
Write a letter … Computer Access Technology 

Corporation 
Customer Support 
3385 Scott Blvd. 
Santa Clara, CA 95054 

Send e-mail… support@CATC.com 
Visit CATC’s web site… http://www.CATC.com/ 
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